cannot load library icui18n

I have tried to get enthought canopy and follow the procedure. However, when I tried to run ./canopy , it gave this error:

Unable to load library icui18n «Cannot load library icui18n: (icui18n: cannot open shared object file: No such file or directory)».

I cannot sudo because I am using the university’s supercomputing account, no permission to do so. Any advice?

2 Answers 2

You just need a copy of ICU installed on the system you are trying to run canopy on. You can do this by either installing it via the OS’s package manager, or by getting a copy in your home directory, and telling canopy where to find it with LD_LIBRARY_PATH .

You can get precompiled copies of ICU from their download page (http://site.icu-project.org/download/51), and once installed you would do something like:

Sorry for the late response (we are monitoring the enthought tag, please use it for to get our attention more quickly).

These warning messages Unable to load library icui18n are spurious and shouldn’t affect the usability of Canopy. We have turned these warnings off in version 1.2, which is coming out during the first week of January. Please post again if you see issues.

Not the answer you’re looking for? Browse other questions tagged python enthought icu canopy or ask your own question.

Linked

Hot Network Questions

To subscribe to this RSS feed, copy and paste this URL into your RSS reader.

site design / logo © 2019 Stack Exchange Inc; user contributions licensed under cc by-sa 4.0 with attribution required. rev 2019.11.15.35459

Я попытался получить восторженный навес и следовать процедуре. Тем не менее, когда я пытался бежать ./canopy Дала эту ошибку:

Невозможно загрузить библиотеку icui18n «Невозможно загрузить библиотеку icui18n: (icui18n: невозможно открыть общий объектный файл: такого файла или каталога нет) «.

Я не могу судо, потому что я использую университетУчетная запись суперкомпьютера, нет разрешения на это. Любой совет?

Вам просто нужна копия ICU, установленная в системе, которую вы пытаетесь запустить canopy на. Вы можете сделать это, либо установив его через ОС ‘с менеджером пакетов, или, получив копию в вашем домашнем каталоге, и сообщив canopy где его найти. LD_LIBRARY_PATH

Вы можете получить предварительно скомпилированные копии ICU со страницы загрузки (http://site.icu-project.org/download/51), и после установки вы сделаете что-то вроде:

Извините за поздний ответ (мы отслеживаем тег enthought, пожалуйста, используйте его, чтобы быстрее привлечь наше внимание).

Эти предупреждающие сообщения Unable to load library icui18n ложные и не должныне влияет на удобство использования Canopy. Мы отключили эти предупреждения в версии 1.2, которая выходит в течение первой недели января. Пожалуйста, напишите снова, если вы видите проблемы.

Affects Status Importance Assigned to Milestone
mumble (Ubuntu) Edit
Unassigned Edit Unassigned Edit

Bug Description

Getting error when trying to start the application.
Unable to load library icui18n «Cannot load library icui18n: (libicui18n.so.48: cannot open shared object file: No such file or directory)»

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: mumble-server 1.2.3-2ubuntu4
Uname: Linux 3.2.13- grsec-xxxx- grs-ipv6- 64 x86_64
ApportVersion: 2.0.1-0ubuntu6
Architecture: amd64
Date: Fri Apr 27 12:57:33 2012
ProcEnviron:
TERM=linux
LANG=en_GB.UTF-8
SHELL=/bin/bash
SourcePackage: mumble
UpgradeStatus: Upgraded to precise on 2012-04-27 (0 days ago)
modified. conffile. .etc.mumble. server. ini: [modified]
mtime.conffile. .etc.default. mumble. server: 2012-04-26T23:45:13
mtime.conffile. .etc.mumble. server. ini: 2012-03-19T19:25:27

Kaizoku (neoark) wrote on 2012-04-27 : #1
  • Dependencies.txtEdit (2.4 KiB, text/plain; charset=»utf-8″)
  • modified.conffile..etc.default.mumble.server.txtEdit (619 bytes, text/plain; charset=»utf-8″)
Launchpad Janitor (janitor) wrote on 2012-04-28 : #2

Status changed to ‘Confirmed’ because the bug affects multiple users.

Changed in mumble (Ubuntu):
status: New → Confirmed
Benjamin Jemlich (pcgod) wrote on 2012-04-28 : #3

The missing dependency has to be in one of the Qt packages because they’re trying to dlopen the ICU library (and murmurd works for me without the ICU lib).

affects: mumble (Ubuntu) → qt4-x11 (Ubuntu)

Qt does not have any build-depends on libicu.

affects: qt4-x11 (Ubuntu) → mumble (Ubuntu)
Benjamin Jemlich (pcgod) wrote on 2012-04-28 : #5

It’s definitely Qt trying to load the libicui18n, see
https:/ /qt.gitorious. org/qt/ qt/blobs/ 4.8/src/ corelib/ tools/qlocale_ icu.cpp
which does include ICU header files.

Benjamin Jemlich (pcgod) wrote on 2012-04-28 : #6

Also libicu-dev is listed as a build dependency in qt4-x11. Maybe libqtcore4 should depend on libicu if it’s needed for their locale stuff.

affects: mumble (Ubuntu) → qt4-x11 (Ubuntu)
Gallomimia (gallomimia) wrote on 2012-05-28 : #7

I get this error, but it does not prevent mumble server from loading. Is there a way to fix it?

Andreas Metzler (k-launchpad-downhill-at-eu-org) wrote on 2012-05-28 : #8

@Gallomimia: You could simply install the libicu48 package to silence the warnings.

Christian Convey (christian-convey) wrote on 2012-09-12 : #9

Just installing the package doesn’t seem sufficient. I have it installed (Mint 13) and get the same error. I suspet it’s that there are no symlinks of the form /usr/lib/foo.so —> /usr/lib/foo.so.48

/packages/ x$ dpkg -L libicu48
/.
/usr
/usr/share
/usr/share/doc
/usr/share/ doc/libicu48
/usr/share/ doc/libicu48/ copyright
/usr/share/ doc/libicu48/ NEWS.Debian. gz
/usr/share/ doc/libicu48/ changelog. Debian. gz
/usr/share/lintian
/usr/share/ lintian/ overrides
/usr/share/ lintian/ overrides/ libicu48
/usr/lib
/usr/lib/ libiculx. so.48.1. 1
/usr/lib/ libicudata. so.48.1. 1
/usr/lib/ libicuio. so.48.1. 1
/usr/lib/ libicutest. so.48.1. 1
/usr/lib/ libicule. so.48.1. 1
/usr/lib/ libicui18n. so.48.1. 1
/usr/lib/ libicutu. so.48.1. 1
/usr/lib/ libicuuc. so.48.1. 1
/usr/lib/ libicutu. so.48
/usr/lib/ libicule. so.48
/usr/lib/ libiculx. so.48
/usr/lib/ libicuio. so.48
/usr/lib/ libicuuc. so.48
/usr/lib/ libicudata. so.48
/usr/lib/ libicui18n. so.48
/usr/lib/ libicutest. so.48
cjc@awesome:

Christian Convey (christian-convey) wrote on 2012-09-12 : #10

Never mind — those symlinks do exist. I don’t know why we’re seeing this.

Оцените статью