bgp cisco packet tracer

BGP (англ. Border Gateway Protocol, протокол граничного шлюза) — основной протокол динамической маршрутизации в Интернете.

Он призван обеспечивать передачу маршрутов между различными сетями (автономными системами) – т. е. маршрутизацию между сетями городов, стран и даже континентов.

То есть обеспечивает работу, в том числе, и глобальных сетей, например, сети Интернет.

В частности, стык между двумя провайдерами организуется через BGP.

Автономная система (AS) в интернете — это система IP-сетей и маршрутизаторов, управляемых одним или несколькими операторами, имеющими единую политику маршрутизации с Интернетом.

При настройке маршрутизатора для использования протокола BGP, необходимо задать, как минимум, следующие настройки:

1) Запустить на маршрутизаторе протокол bgp и задать номер автономной системы для данного маршрутизатора (router bgp 200). Необходимо учитывать, что маршрутизатор может принадлежать только одной автономной системе.

2) Командой neighbor, адреса соседних маршрутизаторов с указанием номеров их автономных систем (например, neighbor 172.16.1.1 remote-as 100).

3) Командой network – адреса всех соседних сетей (например, network 192.168.1.0).

Подготовьте отчёт по данной работе. В отчёте необходимо описать выполнение каждого из заданий (со скриншотами и описанием).

№1. Постройте схему сети по образцу:

На каждый из маршрутизаторов добавьте по два запасных порта.

1) В данной работе для настройки маршрутизаторов необходимо использовать не графический интерфейс, а только консоль.

2) В средних и больших сетях (а именно там используется протокол BGP) большая часть компьютеров (а чаще всего – и все) – используют протокол DHCP.

В данной сети адресация также должна производиться по DHCP.

Создайте на одном из роутеров несколько пулов адресов

3) Интерфейсам маршрутизаторов должны быть назначены статические адреса в соответствие со схемой адресации (см. выше логическую схему сети).

№2. Настройте маршрутизацию BGP на каждом из маршрутизаторов в соответствие с таблицей:

Номер автономной системы

• Запустить на маршрутизаторе протокол bgp и задать номер автономной системы для данного маршрутизатора (например, router bgp 200, где 200 – номер автономной системы, к которой принадлежит данный маршрутизатор). Необходимо учитывать, что маршрутизатор может принадлежать только одной автономной системе.

• Указать командой neighbor адреса соседних маршрутизаторов с указанием номеров их автономных систем (например, neighbor 172.16.1.1 remote-as 100).

• Указать командой network адреса всех соседних сетей (например, network 192.168.1.0).

Пример настройки маршрутизатора Router1:

neighbor 172.16.1.1 remote-as 100 (задаём IP соседнего маршрутизатора и его AS).

neighbor 172.16.0.2 remote-as 300 (задаём IP соседнего маршрутизатора и его AS).

network 192.168.3.0 (задаём все соседние сети).

network 172.16.0.0 (задаём все соседние сети).

network 172.16.1.0 (задаём все соседние сети).

Аналогично настройте остальные роутеры.

№3. Выведите таблицу маршрутизации на каждом из роутеров.

№4. Убедитесь в наличии связи между всеми компьютерами командой tracert.

№5. Добавьте дополнительные маршруты между Router3 и Router4, а также между Router3 и Router2 в таблицу маршрутизации BGP.

№6. Выполните трассировку между PC3 и PC1.

№7. Отключите маршрут от Router3 до Router1.

№8. Выполните трассировку между PC3 и PC1.

Объясните, что произошло.

Практическая работа «Объединение автономных систем, каждая из которых работает на протоколе OSPF с помощью протокола BGP в Cisco Packet Tracer».

Постановка задачи: чаще всего, администратор автономной системы сам решает, какой протокол маршрутизации ему использовать. Однако для связи между автономными системами необходимо использовать протокол BGP.

Обеспечьте взаимодействие AS1 на базе протокола OSPF с другими сетями (по протоколу BGP) в соответствие со следующей схемой:

Сетевые настройки выберите и задайте самостоятельно.

BGP in Packet Tracer

BGP (Border Gateway Protocol) is the core routing protocol of the Internet. It is described as a path vector protocol as BGP does not use traditional IGP (OSPF, EIGRP, RIP) metrics, but makes routing decisions based on path, network policies and/or rulesets. It maintains a table of IP networks or ‘prefixes’ which designate network reachability among autonomous systems (AS).

BGP protocol support has been added in Packet Tracer in the 5.3 version. This allows Cisco CCNP Route students to better understand this complex routing protocol and to be prepared for the simulation questions in the exam.

Internal BGP (iBGP) is currently not supported in Packet Tracer (see screenshot below). iBGP support has still not been added in the new Packet Tracer 7.1.1 version

IOS commands available in Packet Tracer 7.1.1

enable mode

  • show ip bgpexit
  • show ip bgp neighbors
  • show ip bgp summary
  • clear ip bgp *

router bgp mode

  • bgp log-neighbor-changes
  • bgp redistribute-internal
  • bgp router-id A.B.C.D
  • exit
  • neighbor A.B.C.D next-hop-self
  • neighbor A.B.C.D remote-as
  • network A.B.C.D
  • network A.B.C.D mask A.B.C.D
  • redistribute connected / eigrp / ospf / static
  • synchronization
  • timers bgp

Sample BGP network

WAN1 router configuration :

A simple eBGP peering with ISP1 router is configured in the WAN1 router.

interface Serial0/0/0
ip address 156.12.1.6 255.255.255.252
!
router bgp 65000
bgp log-neighbor-changes
no synchronization
neighbor 156.12.1.5 remote-as 10000

ISP1 router configuration :

Several loopback interfaces are configured in ISP1 router to simulate connected networks whose are advertised to WAN1 router through the BGP peering.

interface Loopback0
ip address 156.100.1.1 255.255.255.0
!
interface Loopback1
ip address 156.100.2.1 255.255.255.0
!
interface Loopback2
ip address 156.100.4.1 255.255.254.0
!
interface Serial0/0/0
ip address 156.12.1.5 255.255.255.252
clock rate 500000
!
router bgp 10000
bgp log-neighbor-changes
no synchronization
neighbor 156.12.1.6 remote-as 65000
network 156.100.4.0 mask 255.255.254.0
network 156.100.2.0 mask 255.255.255.0
network 156.100.1.0 mask 255.255.255.0

!

Очередь просмотра

Очередь

  • Удалить все
  • Отключить

YouTube Premium

Хотите сохраните это видео?

  • Пожаловаться

Пожаловаться на видео?

Выполните вход, чтобы сообщить о неприемлемом контенте.

Понравилось?

Не понравилось?

Текст видео

BGP(Border Gateway Protocol) is a protocol which connects 2 autonomous systems. This protocol is classified as an Exterior gateway protocol and is widely used.

This tutorial is dedicated to configuring BGP in Cisco Packet Tracer.

If this helped, Please like , share and subscribe.
Thank You.
Happy Learning!!

Оцените статью