apipa is being used cisco что это

Hi to all,
In a Cisco packet tracer while i am trying to connect the dhcp server to pc it will getting the error like dhcp failed. APIPA is being used.

For this issues this is also one reason.dhcp is not configured correctly.

If we create a vlan’s in the switch’s and we configured dhcp server in the layer 3 switch or layer 2 switch or in router.
VLAN 10
NAME SALES
VLAN 20
NAME DATA
We created two vlan’s now creating dhcp server for that
Switch(config)#ip dhcp pool name sales (should be the vlan name. not any other name.)
Switch(Dhcp-config)#network 192.168.10.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.10.1
Switch(dhcp-config)#exit
Swithc(config)#ip dhcp pool name data
Switch(dhcp-config)#network 192.168.20.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.20.1
Switch(dhcp-config)#exit

2 comments :

Bro I am facing same problem,,

Hello Sharan Kumar! I hope you were able to fix your issue, if not lemme show you an example how to configure DHCP and a gift lol how to configure Voip at the same router.
ip dhcp excluded-address 172.16.1.1 172.16.1.9
ip dhcp excluded-address 172.16.2.1 172.16.2.9
!
ip dhcp pool DATA_SCOPE
network 172.16.2.0 255.255.255.0
default-router 172.16.2.1
dns-server 4.2.2.2
ip dhcp pool VOICE_SCOPE
network 172.16.1.0 255.255.255.0
default-router 172.16.1.1
option 150 ip 172.16.1.1
dns-server 4.2.2.2

interface FastEthernet0/0.100
encapsulation dot1Q 100
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0.200
encapsulation dot1Q 200
ip address 172.16.2.1 255.255.255.0

Remember you need to create two subinterfaces for VLANs, it’s mandatory you define the encapsulation, if you don’t you happen to get the APIPA IP instead of the pool.

From the switch side
interface FastEthernet0/1
switchport mode trunk
// this interface is connected to the router interface fa0/0

We need to create the VLANs DATA and VOICE to join the interfaces
use the option : interfaces range fa0/2 — 24 to add the interfaces to both vlans voice and data the result will something like this:

interface FastEthernet0/2
switchport access vlan 200
switchport mode access
switchport voice vlan 100
!
interface FastEthernet0/3
switchport access vlan 200
switchport mode access
switchport voice vlan 100

You can use the spanning-tree portfast together.
In case of you don’t wanna configure voip just skip the voice option and use only the DHCP DATA. Lemme know if you need more tips. Cheers

So, I have the following network configuration in Packet Tracer.

The router is configured with DHCP. The ports on the switches are configured with access mode — for those that belong to the PCs. The unused ports are shut down. The ports between the switches and the ports between the switch and the router are configured as trunk ports. All the PCs that are connected to the S1 that is directly connected to the R1 get the IP addresses from the router. However, the PCs that are connected to the S2 and S3 don’t — instead they get the message «DHCP request failed, APIPA being used». What could be the problem?

The configurations for R1:

The configuration for S1:

The configurations for S2:

The configurations for S3:

DHCP is not not working and showing a mentioned error.pls support for this.

error log ,pkt file etc is attached.

Thanks in advance..

  • 3731 Просмотров
  • Метки: нет (добавить) apipa
1. Re: DHCP Failed APIPA is being used..

Your ip dhcp pool address has the wrong mask. should be 255.255.255.240

You should also add the exluded address to the config for good measure.

ip dhcp excluded-address 192.168.10.1

  • Мне нравится Показать 1 отметку «Мне нравится» (1)
  • Действия
  • Join this discussion now: Войдите / Register
2. Re: DHCP Failed APIPA is being used..

Hi Kev, Mask is correct and i have checked by excluded the 192.168.10.1 but still no luck.

  • Мне нравится Показать отметки «Мне нравится» (0) (0)
  • Действия
  • Join this discussion now: Войдите / Register
3. Re: DHCP Failed APIPA is being used..

Kev has mentioned the correct sugerency;

Router(config)#ip dhcp pool Admin-Pool

Router(dhcp-config)# network 192.168.10.0 255.255.255.240

Router(config)#ip dhcp excluded-address 192.168.10.1

Now, you must wait, and be patient, or save and open the PT file

  • Мне нравится Показать отметки «Мне нравится» (0) (0)
  • Действия
  • Join this discussion now: Войдите / Register
4. Re: DHCP Failed APIPA is being used..

  • Мне нравится Показать отметки «Мне нравится» (0) (0)
  • Действия
  • Join this discussion now: Войдите / Register
5. Re: DHCP Failed APIPA is being used..

Thanks. Kev it is working now.

  • Мне нравится Показать 1 отметку «Мне нравится» (1)
  • Действия
  • Join this discussion now: Войдите / Register
6. Re: DHCP Failed APIPA is being used..

  • Мне нравится Показать отметки «Мне нравится» (0) (0)
  • Действия
  • Join this discussion now: Войдите / Register

Действия

Войдите / Register to participate in the community & access resources like:

  • IT Training Videos and Webinars
  • Cisco Certification Study Groups
  • Cisco Certification Exam Topics

Register for free now.

Оцените статью