1с проверить существование каталога

Вступайте в мою группу помощник программиста.
В ней мы обсуждаем программирование в 1С.

Работа с файловой системой в языке 1С 8.3, 8.2 (в примерах)

С уважением, Владимир Милькин (преподаватель школы 1С программистов и разработчик обновлятора).

Подписывайтесь и получайте новые статьи и обработки на почту (не чаще 1 раза в неделю).

Вступайте в мою группу ВКонтакте, Одноклассниках, Facebook или Google+ — самые последние обработки, исправления ошибок в 1С, всё выкладываю там в первую очередь.

Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.

Нажмите одну из кнопок, чтобы поделиться:

Объект языка 1С «Файл» позволяет:

  • файл 1С — получить путь к файлу (каталог без имени файла), имя без расширения, только расширение
  • файл 1С — проверить наличие файла
  • файл 1С — определить файл это или каталог
  • файл 1С — получить размер файла
  • файл 1С — работать с атрибутами файла (время измененеия, только чтение, скрытые файлы).

Пример файл 1С — проверка наличия каталога на диске:
Функция ПолучитьКаталогПоИмениФайла(ИмяФайла)

//обращаемся к файлу, на этот момент существование файла не проверяется
Файл = Новый Файл(ИмяФайла);

//напрямую проверяем существование
Если не Файл.Существует() Тогда
Сообщить(«Ошибка. Файл с именем ‘» + ИмяФайла + «‘ не существует»);
Возврат ИмяФайла;
КонецЕсли;

//проверка на каталог
Если Файл.ЭтоКаталог() Тогда
//если последняя буква не «», то добавляем ее
Возврат ?(Прав(СокрП(ИмяФайла), 1) = «», ИмяФайла, СокрП(ИмяФайла) + «»);
КонецЕсли;

//возвращаем путь (т.е. только каталог из имени файла)
Возврат Файл.Путь;

Пример файл 1С — проверка существования файла на диске:
Функция ФайлМожноЗаписывать(ИмяФайла)

//обращаемся к файлу, на этот момент существование файла не проверяется
Файл = Новый Файл(ИмяФайла);

//напрямую проверяем существование
Если не Файл.Существует() Тогда
Сообщить(«Ошибка. Файл с именем ‘» + ИмяФайла + «‘ не существует»);
Возврат ИмяФайла;
КонецЕсли;

//вернет ИСТИНА, если нельзя записывать (т.е. только чтение «установлен»)
Если Файл.ПолучитьТолькоЧтение() Тогда
Попытка
Файл.УстановитьТолькоЧтение(Ложь);
Исключение
//здесь мы окажемся, если у пользователя, под которым работает клиент 1С нет прав снять этот реквизит
Возврат Ложь;
КонецПопытки;
КонецЕсли;

Пример файл 1С — получение размера файла в байтах, килобайтах, мегабайтах:

Оцените статью