1с поиск строки в табличной части

Осуществляет поиск всех строк таблицы значений, удовлетворяющих заданным условиям поиска.

Синтаксис

Метод НайтиСтроки() имеет следующий синтаксис:

А также альтернативный англоязычный синтаксис:

Параметры

Описание параметров метода НайтиСтроки() :

Имя параметра Тип Описание
ПараметрыОтбора Структура Задает условия поиска: ключ структуры определяет имя колонки, по которой будет осуществляться поиск, а значение структуры — искомое значение.
Жирным шрифтом выделены обязательные параметры

Возвращаемое значение

Массив
Массив найденных строк таблицы значений, соответствующих условиям поиска.

Описание

Метод НайтиСтроки() осуществляет поиск строк таблицы значений, удовлетворяющих заданным условиям поиска. В отличие от метода ТаблицаЗначений.Найти(), возвращает все найденные строки.

Доступность

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).

Пример использования

Пример кода с использованием метода НайтиСтроки() :

//Корректировать строку табличной части документа
//»ОС» — наименование табличной части
Тч = Док . ОС ;
Тч[ 0 ] . НалоговаяГруппаОС = Справочники . НалоговыеГруппы . НайтиПоНаименованию ( «Четвертая (с 2004 г)» );
Док . Записать ( РежимЗаписиДокумента . Проведение );

//——————————————————————
//Поиск в табличной части документа
//»Платежи» — наименование табличной части
Сообщить ( Док . Платежи . Найти ( ТоЧтоНужноНайти , «РеквизитВТабЧастиГдеИскатьЗначение» )[ «РеквизитВТабЧастиОткудаВзятьЗначение» ]);

//——————————————————————
//Cделать текущей строку табличной части формы документа
//»Выписки» — наименование табличной части
ЗаписьВыписка = ДокБанковскаяВыписка . Выписки . Добавить ();
ЗаписьВыписка . Реквизит1 = «Реквизит1» ;
ЗаписьВыписка . Реквизит2 = «Реквизит2» ;

ФормаВыписка = ДокБанковскаяВыписка . ПолучитьФорму ( «ФормаДокумента» );
ФормаВыписка . ЭлементыФормы . Выписки . ТекущаяСтрока = ЗаписьВыписка ;
ФормаВыписка . Открыть ();

//——————————————————————
//Удалить записи из табличной части документа с помощью структуры
Отбор = Новый Структура ;
Отбор . Вставить ( «КодОбъекта» , ЗначениеКодОбъекта );

Документ = Документы . ПриходнаяНакладная . НайтиПоНаименованию ( «Наименование» ). ПолучитьОбъект ();

//Удаляем записи табличной части
ЗаписиТабЧасти = Документ [ «НазваниеТабЧасти» ]. НайтиСтроки ( Отбор );
Для Каждого ЗаписьТабЧасти Из ЗаписиТабЧасти Цикл
Документ [ «НазваниеТабЧасти» ]. Удалить ( ЗаписьТабЧасти );
КонецЦикла;

//——————————————————————
//Удалить строки (записи) из табличной части документа в цикле (при переборе)
Док = ДокБанковскаяВыписка . ПолучитьОбъект ();
КоличествоЗаписей = Док . Выписки . Количество ();
КоличествоОборотов = 0 ;
Для ъ = 0 По КоличествоЗаписей — 1 Цикл
КоличествоОборотов = КоличествоОборотов + 1 ;

Если Док . Выписки [ ъ ]. ИмяПоля = Истина Тогда
Док . Выписки . Удалить ( Док . Выписки [ ъ ]);
ъ = ъ — 1 ;
КонецЕсли;

Если КоличествоОборотов = КоличествоЗаписей Тогда
Прервать;
КонецЕсли;
КонецЦикла;
Док . Записать ();

Для того чтобы найти строки таблицы значений, которые соответствуют определенным условиям отбора, используется метод НайтиСтроки( ). Параметры отбора представляют из себя структуру, где ключ — это имя колонки таблицы, а значение — значение, по которому будет осуществляться поиск в данной колонке. Поиск элементов будет осуществляться только на равенство. Данный метод возвращает массив найденных строк таблицы, если такие имеются, либо пустой массив, если по данным условиям ничего не найдено.

Таблица значений найти строки. Пример

Пример. Пусть у нас есть Таблица значений содержащаяся в переменной ТЗ, у которой присутствуют колонки с именами Наименование и Код.

Оцените статью